You are here
Home > Preporuke > Sigurnosni nedostatak programskog paketa rh-haproxy18

Sigurnosni nedostatak programskog paketa rh-haproxy18

  • Detalji os-a: WN7
  • Važnost: IMP
  • Operativni sustavi: L
  • Kategorije: LRH

—–BEGIN PGP SIGNED MESSAGE—–
Hash: SHA256

=====================================================================
Red Hat Security Advisory

Synopsis: Important: rh-haproxy18-haproxy security update
Advisory ID: RHSA-2018:1372-01
Product: Red Hat Software Collections
Advisory URL: https://access.redhat.com/errata/RHSA-2018:1372
Issue date: 2018-05-14
CVE Names: CVE-2018-10184
=====================================================================

1. Summary:

An update for rh-haproxy18-haproxy is now available for Red Hat Software
Collections.

Red Hat Product Security has rated this update as having a security impact
of Important. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available for each vulnerability
from the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7) – x86_64
Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.3) – x86_64
Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.4) – x86_64
Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.5) – x86_64
Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 7) – x86_64

3. Description:

HAProxy is a TCP/HTTP reverse proxy which is particularly suited for high
availability environments.

Security Fix(es):

* haproxy: Heap buffer overflow in mux_h2.c:h2_process_demux() can allow
attackers to cause a denial of service (CVE-2018-10184)

For more details about the security issue(s), including the impact, a CVSS
score, and other related information, refer to the CVE page(s) listed in
the References section.

4. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

5. Bugs fixed (https://bugzilla.redhat.com/):

1569297 – CVE-2018-10184 haproxy: Heap buffer overflow in mux_h2.c:h2_process_demux() can allow attackers to cause a denial of service

6. Package List:

Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7):

Source:
rh-haproxy18-haproxy-1.8.4-2.el7.src.rpm

x86_64:
rh-haproxy18-haproxy-1.8.4-2.el7.x86_64.rpm
rh-haproxy18-haproxy-debuginfo-1.8.4-2.el7.x86_64.rpm
rh-haproxy18-haproxy-syspaths-1.8.4-2.el7.x86_64.rpm

Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.3):

Source:
rh-haproxy18-haproxy-1.8.4-2.el7.src.rpm

x86_64:
rh-haproxy18-haproxy-1.8.4-2.el7.x86_64.rpm
rh-haproxy18-haproxy-debuginfo-1.8.4-2.el7.x86_64.rpm
rh-haproxy18-haproxy-syspaths-1.8.4-2.el7.x86_64.rpm

Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.4):

Source:
rh-haproxy18-haproxy-1.8.4-2.el7.src.rpm

x86_64:
rh-haproxy18-haproxy-1.8.4-2.el7.x86_64.rpm
rh-haproxy18-haproxy-debuginfo-1.8.4-2.el7.x86_64.rpm
rh-haproxy18-haproxy-syspaths-1.8.4-2.el7.x86_64.rpm

Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.5):

Source:
rh-haproxy18-haproxy-1.8.4-2.el7.src.rpm

x86_64:
rh-haproxy18-haproxy-1.8.4-2.el7.x86_64.rpm
rh-haproxy18-haproxy-debuginfo-1.8.4-2.el7.x86_64.rpm
rh-haproxy18-haproxy-syspaths-1.8.4-2.el7.x86_64.rpm

Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 7):

Source:
rh-haproxy18-haproxy-1.8.4-2.el7.src.rpm

x86_64:
rh-haproxy18-haproxy-1.8.4-2.el7.x86_64.rpm
rh-haproxy18-haproxy-debuginfo-1.8.4-2.el7.x86_64.rpm
rh-haproxy18-haproxy-syspaths-1.8.4-2.el7.x86_64.rpm

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2018-10184
https://access.redhat.com/security/updates/classification/#important

8. Contact:

The Red Hat security contact is <secalert@redhat.com>. More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2018 Red Hat, Inc.
—–BEGIN PGP SIGNATURE—–
Version: GnuPG v1

iQIVAwUBWvsF4dzjgjWX9erEAQjwLRAAmZRxIe6TgdhhozGjibxPfKhXq6im69Ko
rt8J6eXzUSbIkKR+cdK3+UJyAtPVyk/NNqArDzd4nmcVZLZkeDVMw8Ts5oos9lmh
X3Oxzxgi9U3fYwIk8fbVhb6JPuoSSQMnUYh3b1g4WXi/DHVU670Or7gKr1SpA6kD
ENHFLAHUT0Nn6qYxAypryKoPE5xwQf2sNSo/FbHu/T2f+5sqzgHImcInxw0bZIAa
zYuVt6rFkOnelgUVo8yorEWFBSEB9MoBRfuUpjsOvdCJl6p4ZSznwWBb3XY3IQn2
LOhYELA8OVVtOsdttGiuYeZ4Ds2+80Z0sGZ28LGWvk9LLtxdIMMuoqDGV/pDeBjh
S5kgrjtyJNXOIREGY36FskrN1xcwIRsSHs1YFXDHWSb+TzmLoSngSUTrCGJM5aUP
kDBNKVPiJyDJ9Vf/Im6JNqxe5GZoOlNa3MBQ02lgYeBWdzkzGRlP+qy2rezsgOdj
2+MS/+2i5k3RQzjvYELxpaqOYLYIbqvG4eCHT2NlLo8s4rfGyyBPiiMT0eRJ5jan
gS6HeklVbhJbBF/9pwdSIc0XPwEks03514qwQVYQLFV5gASkG4+FbruAMgVWfqp5
aOYS/k6FNnu2meI1EAMLZDrmPh7BQuGajSM2qTz8D+kKtFQda6FIqyDUK5LMlGKi
uS56DYj3Kpo=
=NGCm
—–END PGP SIGNATURE—–


RHSA-announce mailing list
RHSA-announce@redhat.com
https://www.redhat.com/mailman/listinfo/rhsa-announce

AutorDanijel Kozinovic
Cert idNCERT-REF-2018-05-0001-ADV
CveCERT-CVE-DUMMY
ID izvornikaCERT-ORIGID-DUMMY
ProizvodCERT-DUMMY-PRODUCT
IzvorAdobe
Top