You are here
Home > Preporuke > Sigurnosni nedostaci programskog paketa cups

Sigurnosni nedostaci programskog paketa cups

  • Detalji os-a: WN7
  • Važnost: IMP
  • Operativni sustavi: L
  • Kategorije: LSU

openSUSE Security Update: Security update for cups
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:2239-1
Rating: moderate
References: #1050082 #1061066 #1087018 #1096405 #1096406
#1096407 #1096408
Cross-References: CVE-2017-18248 CVE-2018-4180 CVE-2018-4181
CVE-2018-4182 CVE-2018-4183
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that solves 5 vulnerabilities and has two fixes
is now available.

Description:

This update for cups fixes the following issues:

The following security vulnerabilities were fixed:

– CVE-2017-18248: Handle invalid characters properly in printing jobs.
This fixes a problem that was causing the DBUS library to abort the
calling process. (bsc#1061066 bsc#1087018)
– Fixed a local privilege escalation to root and sandbox bypasses in the
scheduler
– CVE-2018-4180: Fixed a local privilege escalation to root in dnssd
backend (bsc#1096405)
– CVE-2018-4181: Limited local file reads as root via cupsd.conf include
directive (bsc#1096406)
– CVE-2018-4182: Fixed a sandbox bypass due to insecure error handling
(bsc#1096407)
– CVE-2018-4183: Fixed a sandbox bypass due to profile misconfiguration
(bsc#1096408)

The following other issue was fixed:

– Fixed authorization check for clients (like samba) connected through the
local socket when Kerberos authentication is enabled (bsc#1050082)

This update was imported from the SUSE:SLE-12:Update update project.

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or “zypper patch”.

Alternatively you can run the command listed for your product:

– openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-822=1

Package List:

– openSUSE Leap 42.3 (i586 x86_64):

cups-1.7.5-12.6.1
cups-client-1.7.5-12.6.1
cups-client-debuginfo-1.7.5-12.6.1
cups-ddk-1.7.5-12.6.1
cups-ddk-debuginfo-1.7.5-12.6.1
cups-debuginfo-1.7.5-12.6.1
cups-debugsource-1.7.5-12.6.1
cups-devel-1.7.5-12.6.1
cups-libs-1.7.5-12.6.1
cups-libs-debuginfo-1.7.5-12.6.1

– openSUSE Leap 42.3 (x86_64):

cups-libs-32bit-1.7.5-12.6.1
cups-libs-debuginfo-32bit-1.7.5-12.6.1

References:

https://www.suse.com/security/cve/CVE-2017-18248.html
https://www.suse.com/security/cve/CVE-2018-4180.html
https://www.suse.com/security/cve/CVE-2018-4181.html
https://www.suse.com/security/cve/CVE-2018-4182.html
https://www.suse.com/security/cve/CVE-2018-4183.html
https://bugzilla.suse.com/1050082
https://bugzilla.suse.com/1061066
https://bugzilla.suse.com/1087018
https://bugzilla.suse.com/1096405
https://bugzilla.suse.com/1096406
https://bugzilla.suse.com/1096407
https://bugzilla.suse.com/1096408


To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org

AutorZvonimir Bosnjak
Cert idNCERT-REF-2018-08-0001-ADV
CveCERT-CVE-DUMMY
ID izvornikaCERT-ORIGID-DUMMY
ProizvodCERT-DUMMY-PRODUCT
IzvorAdobe
Top