You are here
Home > Preporuke > Sigurnosni nedostaci programskog paketa clamav

Sigurnosni nedostaci programskog paketa clamav

  • Detalji os-a: WN7
  • Važnost: IMP
  • Operativni sustavi: L
  • Kategorije: LSU

openSUSE Security Update: Security update for clamav
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:2259-1
Rating: moderate
References: #1101410 #1101412 #1101654 #1103040
Cross-References: CVE-2018-0360 CVE-2018-0361
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that solves two vulnerabilities and has two fixes
is now available.

Description:

This update for clamav to version 0.100.1 fixes the following issues:

The following security vulnerabilities were addressed:

– CVE-2018-0360: HWP integer overflow, infinite loop vulnerability
(bsc#1101410)
– CVE-2018-0361: PDF object length check, unreasonably long time to parse
relatively small file (bsc#1101412)
– Buffer over-read in unRAR code due to missing max value checks in table
initialization
– Libmspack heap buffer over-read in CHM parser (bsc#1103040)
– PDF parser bugs

The following other changes were made:

– Disable YARA support for licensing reasons (bsc#1101654).
– Add HTTPS support for clamsubmit
– Fix for DNS resolution for users on IPv4-only machines where IPv6 is not
available or is link-local only

This update was imported from the SUSE:SLE-15:Update update project.

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or “zypper patch”.

Alternatively you can run the command listed for your product:

– openSUSE Leap 15.0:

zypper in -t patch openSUSE-2018-838=1

Package List:

– openSUSE Leap 15.0 (x86_64):

clamav-0.100.1-lp150.2.3.1
clamav-debuginfo-0.100.1-lp150.2.3.1
clamav-debugsource-0.100.1-lp150.2.3.1
clamav-devel-0.100.1-lp150.2.3.1
libclamav7-0.100.1-lp150.2.3.1
libclamav7-debuginfo-0.100.1-lp150.2.3.1
libclammspack0-0.100.1-lp150.2.3.1
libclammspack0-debuginfo-0.100.1-lp150.2.3.1

References:

https://www.suse.com/security/cve/CVE-2018-0360.html
https://www.suse.com/security/cve/CVE-2018-0361.html
https://bugzilla.suse.com/1101410
https://bugzilla.suse.com/1101412
https://bugzilla.suse.com/1101654
https://bugzilla.suse.com/1103040


To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org

AutorDanijel Kozinovic
Cert idNCERT-REF-2018-08-0001-ADV
CveCERT-CVE-DUMMY
ID izvornikaCERT-ORIGID-DUMMY
ProizvodCERT-DUMMY-PRODUCT
IzvorAdobe
Top